Author Topic: [HID] Can't get data after HidD_SetOutputReport(same meaning as writefile)  (Read 6616 times)

agent2

  • Member
  • ***
  • Posts: 3
Dear Jan,

I'm your book reader. I start my USB communication project following by your code in the Book and Web site.

The main reference is "usbhidio_V2.3.cs"

My USB device is a standard USB HID with 3 Endpoints normally.
Test tool: Bus Hound.

The main problem is :
I can do the SetOutputreport to the Device and success with the GetInputReportData, But there is no data inside.

After check the BusHound, there are actually data back but not in my pipe. I thought maybe some delegate/invoke issue and I can't debug it after weeks..

Could you give me advice or show me some example codes more to let me compare? Or I can send you the resource code by email.

Any response is welcome, thanks.

BR,

     Johnny T.

agent2

  • Member
  • ***
  • Posts: 3
Dear Jan,

Posted my BusHound tool's screen. The data communication is correct.

    Johnny.

Jan Axelson

  • Administrator
  • Frequent Contributor
  • *****
  • Posts: 2742
    • Lakeview Research
The device is sending 32 bytes from the interrrupt IN endpoint? Is your ReadFile buffer at least 33 bytes?

Jan

agent2

  • Member
  • ***
  • Posts: 3
Dear Jan,
in my code, I can get 64 bytes of byte array, but there are all empty data in them.

Should I send you my code for reference?

Jan Axelson

  • Administrator
  • Frequent Contributor
  • *****
  • Posts: 2742
    • Lakeview Research
Does my example application work if you increase the buffer size?

You are sure the device is sending the data?

You can post or attach a code excerpt here.

Jan