Author Topic: A point in the right direction please, odd USB/FPS issue.  (Read 111 times)

almstsobur

  • Member
  • ***
  • Posts: 2
A point in the right direction please, odd USB/FPS issue.
« on: November 04, 2019, 02:27:48 pm »
  I am hoping someone with a lot more expertise than mself about USB and Windows 10 can maybe point me in the direction I should looking to resolve an issue with a Direct Drive Force Feedback wheel and Microsoft racing titles. In this particular situation I am talking about Forza Horizon 4 and Forza Motorsports 7. I do not have this issue with any other racing simulation titles, just these two, the only two I own that come from the Microsoft store and are published by companies that Microsoft owns.

     The issue is a huge frame per second hit as soon as I plug in the direct drive wheel. In testing I can be using the keyboard or gamepad and be racing along at 85-100FPS, while in game I plug in the USB plug for the DD wheel and instantly lose 40-50% FPS, it will drop immediately to 48-58 FPS. This is repeatable, like clockwork. I do not get a CPU usage spike or anything else that seems out of the ordinary, these particular games use very little of the full capability of my Ryzen 3800X processor. Another thing of note, my motherboard has 2 different USB chipsets on it and I bought a PCI-E add on USB 3.1 card for testing and interestingly enough found differences in the impact based on what USB port I use. One of the onboard USB chipsets will have a 60% FPS hit, the other 50% and the add-on card has the least impact at maybe ~40%. I have tried driver updates, logging performance, different cables, you name it. I have tried everything I am capable of to try to fix this over the past few months. This issue is also not machine specific, a completely different computer of mine acts the same way and other users have reported the same issue with the particular wheel and these particular titles.
 
     If anyone can just tell me what types of things could cause this, I donít mind doing the research and testing, I am just at a loss as to what I should be looking for at this point. As far as I can tell; the DD wheel controller board is based on NXP LPC1768 Cortex M3 with a AN11018 USB interface. Any assistance in what might cause such an issue, or how to troubleshoot this would be greatly appreciated.

Thank You

Jan Axelson

  • Administrator
  • Frequent Contributor
  • *****
  • Posts: 2871
    • Lakeview Research
Re: A point in the right direction please, odd USB/FPS issue.
« Reply #1 on: November 04, 2019, 08:30:07 pm »
Take a look at this discussion if you haven't seen it:

https://steamcommunity.com/app/389730/discussions/0/1291817837636637944/

almstsobur

  • Member
  • ***
  • Posts: 2
Re: A point in the right direction please, odd USB/FPS issue.
« Reply #2 on: November 05, 2019, 04:22:11 pm »
Take a look at this discussion if you haven't seen it:

https://steamcommunity.com/app/389730/discussions/0/1291817837636637944/

Jan, I appreciate the reply and I had not seen that thread before. Although, it did not directly resolve my issue, I believe this is exactly what I needed. For the first time ever; I can have that USB cable in and get a normal frame rate, though the wheel is not seen properly within the game. However, this tells me almost directly where the problem lies and I can certainly work with this. Thank You very much.

Jan Axelson

  • Administrator
  • Frequent Contributor
  • *****
  • Posts: 2871
    • Lakeview Research
Re: A point in the right direction please, odd USB/FPS issue.
« Reply #3 on: November 05, 2019, 06:25:15 pm »
Wonderful! Thanks for reporting back.